Deliverability Degraded

Incident

Deliverability Degraded

Status: closed
Start:
End:
Duration: 8 hours 25 minutes
Affected Components:
2. Delivery Service - US
Update

We're currently investigating a degradation in deliverability affecting part of our infrastructure. 
Our team is actively working on the issue, and we'll share updates as more information becomes available.

Update

We are still actively investigating the deliverability issue affecting a subset of our infrastructure.

For any specific questions or assistance, please reach out to our support team through our ticket portal or contact our 24/7 hotline at +1 (917) 830-8262We'll continue to provide updates as more information becomes available.

Resolved

Our team has implemented a remediation, and all affected services should now be operating as expected. For any additional questions, please do not hesitate to reach out to your support team for assistance.

We appreciate your patience and understanding throughout this process.